- Windows
- Internet & Network
- Network Tools
- Klever PumpKIN
Klever PumpKIN
Description
Download of Klever PumpKIN 2.7.3 was on the developer's website when we last checked. We cannot confirm if there is a free download of this software available. The program's installer file is generally known as PumpKIN.exe.
The following versions: 2.7, 2.6 and 2.0 are the most frequently downloaded ones by the program users. This free PC software was developed to work on Windows XP, Windows XP Professional, Windows Vista, Windows 7, Windows 8, Windows 10 or Windows 11 and can function on 32-bit systems.
The program relates to Internet & Network Tools. According to the results of the Google Safe Browsing check, the developer's site is safe. Despite this, we recommend checking the downloaded files with any free antivirus software. This free program is an intellectual property of Klever Group.
From the developer:
PumpKIN is an open-source fully functional free TFTP server and TFTP client, which implements TFTP according to RFC1350. It also implements block size option, which allows transfer of files over 32MB, as well as transfer size and transfer timeout options described in RFC2348 and RFC2349.
The primary use of PumpKIN is maintenance of the network equipment (such as router firmware upgrade) that fetches images from TFTP server, although it is also useful for transferring files between parties involved in a conversation over ntalk connection using our T42 software (it also detects ntalk conversation held over now obsolete program 'wintalk').
You may want to check out more software, such as Klever KINSole, Halloween Pumpkins or Evil Pumpkin The Lost Halloween, which might be related to Klever PumpKIN.
Comments
Subscribe to commentsPlease add a comment explaining the reasoning behind your vote.